Issues with Payments
Resolved
Partial outage
Lasted for 49m

We've resolved the issue, and all impacted customers should now be able to take payments. Thanks for bearing with us and we apologize for the disruption.

Fri, Jun 24, 2022, 06:59 PM
1 year ago
Affected components
Updates

Resolved

We've resolved the issue, and all impacted customers should now be able to take payments. Thanks for bearing with us and we apologize for the disruption.

Fri, Jun 24, 2022, 06:59 PM

Monitoring

We're continuing to see signs of improvement and are monitoring the situation.

Fri, Jun 24, 2022, 06:50 PM
16m earlier...

Monitoring

We are seeing improvements and most payments should be going through normally again. We'll be back with another update as soon as we have more information.

Fri, Jun 24, 2022, 06:34 PM

Investigating

We're still investigating the elevated error rates. We do apologize for any disruption.

Fri, Jun 24, 2022, 06:29 PM
18m earlier...

Investigating

We are investigating elevated error rates with payments. We’re on the case and will provide another update once we have more details to share. We’re sorry for the inconvenience.

Fri, Jun 24, 2022, 06:10 PM