Issues with the 3G in the Netherlands
Resolved
Degraded performance
Lasted for 3h

This incident has been resolved.

Tue, Mar 1, 2022, 05:34 PM
2 years ago
Affected components
Updates

Resolved

This incident has been resolved.

Tue, Mar 1, 2022, 05:34 PM
3h earlier...

Investigating

We are investing an issue with the 3G terminal in the Netherlands.

Tue, Mar 1, 2022, 02:28 PM