Issues with Virtual Terminal on web
Resolved
Degraded performance
Lasted for 2h

We can confirm that the issue has been resolved. If you continue to experience issues, please contact our customer support. We apologize for the inconvenience this might have caused you and thank you for your patience.

Mon, Feb 28, 2022, 04:49 PM
2 years ago
Affected components
Updates

Resolved

We can confirm that the issue has been resolved. If you continue to experience issues, please contact our customer support. We apologize for the inconvenience this might have caused you and thank you for your patience.

Mon, Feb 28, 2022, 04:49 PM

Monitoring

We have implemented a fix and are monitoring the situation. All users should be able to make transactions through the Virtual Terminal again.

Mon, Feb 28, 2022, 04:46 PM
29m earlier...

Identified

We are continuing to work on a fix. Thank you for bearing with us.

Mon, Feb 28, 2022, 04:17 PM
52m earlier...

Identified

We have narrowed down the issue and are working on a fix.

Mon, Feb 28, 2022, 03:25 PM
13m earlier...

Investigating

We are continuing to investigate and will share another update as soon as we have it. Thank you for your patience.

Mon, Feb 28, 2022, 03:11 PM
29m earlier...

Investigating

We are looking into an issue that is preventing the Virtual Terminal page from loading in some browsers. Users who are affected by this can use Firefox or the mobile app to take payments for the time being. We apologize for the inconvenience and will share an update soon.

Mon, Feb 28, 2022, 02:42 PM