Issues with Payments
Resolved
Degraded performance
Lasted for 9m

This incident has been resolved. We're terribly sorry for the disruption, and we very much appreciate your patience.

Tue, Nov 30, 2021, 06:11 AM
2 years ago
Affected components
Updates

Resolved

This incident has been resolved. We're terribly sorry for the disruption, and we very much appreciate your patience.

Tue, Nov 30, 2021, 06:11 AM

Monitoring

A fix has been implemented and we are monitoring the results.

Tue, Nov 30, 2021, 06:06 AM

Identified

The issue has been identified and a fix is being implemented.

Tue, Nov 30, 2021, 06:04 AM

Investigating

We are investigating reports of degraded performance for our Payments.

Tue, Nov 30, 2021, 06:01 AM