Resolved
All phone lines, including TIM operated ones, are operational again. Sorry for the inconvenience.
Investigating
We are investigating an issue with our phone carrier partner TIM.
If you are trying to reach SumUp, please use the following phone number until the issues are resolved: 30807797