Invoicing service degraded
Resolved
Degraded performance
Lasted for 1m

Incident is resolved.

Thu, Jun 15, 2023, 02:35 PM
11 months ago
Affected components
Invoices
Updates

Resolved

Incident is resolved.

Thu, Jun 15, 2023, 02:35 PM

Identified

There is an information what we would like to share. We are working on this and update you as as soon as possible. Sorry for inconveniences.

Thu, Jun 15, 2023, 02:34 PM