invoices/quotes are not being received by customers
Resolved
Degraded performance
Lasted for 51m

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Wed, Nov 29, 2023, 02:20 PM
5 months ago
Affected components
Invoices
Updates

Resolved

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Wed, Nov 29, 2023, 02:20 PM
51m earlier...

Investigating

Some merchants are complaining that invoices/quotes they issued did not reach their customers, we’re looking into it

There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.

Wed, Nov 29, 2023, 01:28 PM