Business Account - 3DS service disruption
Resolved
Partial outage

The issue is resolved.

Our engineering team has resolved the problem and the services are back to normal.

Wed, Dec 13, 2023, 10:30 PM
9 months ago
Affected components
Business Account (EU)
Updates

Resolved

The issue is resolved.

Our engineering team has resolved the problem and the services are back to normal.

Wed, Dec 13, 2023, 10:30 PM
1h earlier...

Identified

Issue identified, working on a fix right now

Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Wed, Dec 13, 2023, 08:33 PM

Investigating

An issue with the SumUp Card 3DS functionality has been identified, we’re looking into it

There’s currently an issue with our 3DS service. Customers may experience issues when trying to do online payments with their SumUp card. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.

Wed, Dec 13, 2023, 08:32 PM