Issues with sumup.com
Resolved·Full outage

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Wed, Aug 7, 2024, 10:59 PM
(10 months ago)
·
Affected components
Dashboard
Online Store
SumUp Website
Updates

Resolved

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Wed, Aug 7, 2024, 10:59 PM

Monitoring

We applied a fix for the problem, we’re monitoring the situation

SumUp services have returned to normal. Our engineering team will monitor the situation to make sure the issue is solved. We’ll post current information here on our status page.

Wed, Aug 7, 2024, 07:49 PM(3 hours earlier)

Investigating

An issue has been identified, we’re looking into it

We are experiencing issues with the sumup.com website. This includes the merchant dashboard, support center and online store.

Mobile applications continue to work fine and payments are not affected.

We will update this page as more information is available.

Wed, Aug 7, 2024, 07:40 PM