Invoices creation fails for some users
Resolved
Partial outage

Issue identified, working on a fix right now

Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Tue, Mar 25, 2025, 10:41 AM
2d ago
Affected components
Invoices
Updates

Resolved

Issue identified, working on a fix right now

Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Tue, Mar 25, 2025, 10:41 AM
35m earlier...

Identified

Currently some users are facing issues in creation of invoices. Out team is looking into it

Tue, Mar 25, 2025, 10:05 AM