Cellular connection issues
Resolved
Degraded performance

Issue has been resolved, cellular connectivity is recovering.

Wed, Mar 26, 2025, 10:32 AM
3d ago
Affected components
Updates

Resolved

Issue has been resolved, cellular connectivity is recovering.

Wed, Mar 26, 2025, 10:32 AM
17m earlier...

Monitoring

Issue has been identified and fixed, Mobile data is recovering You can stay up to date here on our status page.

Wed, Mar 26, 2025, 10:14 AM
54m earlier...

Identified

Issue identified, working on a fix right now

Our mobile data provider has been experiencing instabilities, preventing European card readers connected to LTE/ Cat-M network from accessing the internet.

While our provider is working to resolve the issue, merchants can continue using card reader over WiFi or Bluetooth via the SumUp App. These connection options are available in the settings.

You can find up-to-date information here on our status page.

Wed, Mar 26, 2025, 09:19 AM

Identified

An issue has been identified, we’re looking into it

For the last 12 hours, our mobile data provider has been experiencing instabilities, preventing European card readers connected to LTE/ Cat-M network from accessing the internet. While our provider is working to resolve the issue, merchants can continue using card reader over WiFi or Bluetooth via the SumUp App. These connection options are available in the settings. You can find up-to-date information here on our status page.

Wed, Mar 26, 2025, 09:13 AM