Outbound transfers delayed for some EU merchants
Resolved
Degraded performance

The issue has been fixed and we’re confident it’s resolved

On Thursday, 27th March, we experienced a technical issue causing duplication of some outgoing transfers from SumUp Business Accounts. Impacted customers have been directly notified via email. We have initiated recalls for all duplicated transactions. If you receive a recall request from your bank, please approve it promptly. Thank you to those who have already approved these recall requests. 

Please be aware that due to this incident, outbound transfers may have experienced delays over the weekend. This issue has now been resolved. All pending transfers have been processed correctly, and normal operations have resumed.

Sun, Mar 30, 2025, 10:15 AM
2d ago
Affected components
Business Account (EU)
Updates

Resolved

The issue has been fixed and we’re confident it’s resolved

On Thursday, 27th March, we experienced a technical issue causing duplication of some outgoing transfers from SumUp Business Accounts. Impacted customers have been directly notified via email. We have initiated recalls for all duplicated transactions. If you receive a recall request from your bank, please approve it promptly. Thank you to those who have already approved these recall requests. 

Please be aware that due to this incident, outbound transfers may have experienced delays over the weekend. This issue has now been resolved. All pending transfers have been processed correctly, and normal operations have resumed.

Sun, Mar 30, 2025, 10:15 AM
1d earlier...

Identified

On Thursday, 27th March, we experienced a technical issue causing duplication of some outgoing transfers from SumUp Business Accounts. Impacted customers have been directly notified via email. We have initiated recalls for all duplicated transactions. If you receive a recall request from your bank, please approve it promptly. Thank you to those who have already approved these recall requests. Please be aware that due to this incident, outbound transfers may experience delays over the upcoming weekend. We are working to address the issue.

Fri, Mar 28, 2025, 10:51 PM