Maintenance of SumUp Card
Complete·Under maintenance

Maintenance work finished.

Wed, May 28, 2025, 04:41 AM
(1 day ago)
·
Affected components
Business Account (EU)
Updates

Complete

Maintenance work finished.

Wed, May 28, 2025, 04:41 AM

In progress

Maintenance still in progress for 10min more.

Wed, May 28, 2025, 04:19 AM(22 minutes earlier)

Complete

Maintenance has completed

Wed, May 28, 2025, 04:15 AM

In progress

Maintenance has started

Wed, May 28, 2025, 04:05 AM(10 minutes earlier)

Scheduled

We will be conducting a brief maintenance on the infrastructure supporting SumUp Card. During this maintenance period, some card transactions may be temporarily declined. If this happens, please simply retry your transaction. We apologize for any inconvenience this may cause.

Mon, May 26, 2025, 02:25 PM(1 day earlier)