Complete
Maintenance finished
In progress
Maintenance is still ongoing
Complete
Maintenance has completed
In progress
Maintenance has started
Scheduled
We are performing maintenance on our SEPA transfer systems. As a result, both incoming and outgoing SEPA transfers may experience delays. We apologize for any inconvenience and appreciate your understanding.