An issue has been identified, we’re looking into it
There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.
Resolved
An issue has been identified, we’re looking into it
There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.
Investigating
Our regular payout schedule has been interrupted due to a technical issue. Some payouts may be slightly delayed. We are working to resolve the issue as swiftly as possible in order to minimise any such possible delays. We apologise for any inconvenience, and thank you sincerely for your patience and understanding.
Identified
Our regular payout schedule has been interrupted due to a technical issue. Some payouts may be slightly delayed. We are working to resolve the issue as swiftly as possible in order to minimise any such possible delays. We apologise for any inconvenience, and thank you sincerely for your patience and understanding.
Identified
An issue has been identified, we’re looking into it
There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.