Online Store and Sales History & Receipts are having problems
Resolved·Degraded performance

Applied a fix for the problem, all systems have recovered. SumUp services have returned to normal. Our engineering team monitored the situation to make sure the issue was solved. We don’t see any issue anymore.

Thu, Oct 30, 2025, 04:19 PM
(1 hour ago)
·
Affected components
Online Store
Updates

Resolved

Applied a fix for the problem, all systems have recovered. SumUp services have returned to normal. Our engineering team monitored the situation to make sure the issue was solved. We don’t see any issue anymore.

Thu, Oct 30, 2025, 04:19 PM

Monitoring

We have identified the issue and applied a fix. We’re monitoring to ensure everything is back to normal. There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.

Thu, Oct 30, 2025, 02:48 PM(1 hour earlier)

Investigating

An issue has been identified with a few products, such as Sales History, Receipts and Online Store; we’re looking into it There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.

Thu, Oct 30, 2025, 02:21 PM(27 minutes earlier)