Sales History shows sales with a slight delay
Monitoring·Degraded performance

Issue identified, we have applied a fix and currently monitoring Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Sat, Dec 6, 2025, 02:03 PM
(2 hours ago)
·
Affected components
Updates

Monitoring

Issue identified, we have applied a fix and currently monitoring Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Sat, Dec 6, 2025, 02:03 PM

Identified

An issue has been identified, we’re looking into it There’s currently an issue with some SumUp services that causes Sales History to show the processed sales with a slight delay. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.

Sat, Dec 6, 2025, 01:30 PM(32 minutes earlier)