SumUp

Support centerSubscribe to updates
Status pages / Europe
Powered by
Privacy policy

·

Terms of service
Some payments failing
Identified·Degraded performance

Issue identified, working on a fix right now

Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Sat, Jun 27, 2026, 03:01 PM
(40 minutes ago)
·
Affected components
02:14 PM
Now
Updates

Identified

Issue identified, working on a fix right now

Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Sat, Jun 27, 2026, 03:01 PM

Identified

Issue identified, working on a fix right now

Our engineering team has found the cause of the problem and is working to return our services to normal. You can stay up to date here on our status page.

Sat, Jun 27, 2026, 02:07 PM(54 minutes earlier)

Investigating

An issue has been identified, we’re looking into it

There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.

Sat, Jun 27, 2026, 01:32 PM(35 minutes earlier)