Issues with Logins
Incident Report for SumUp
Resolved
This incident has been resolved.
Posted May 28, 2021 - 18:02 CEST
Identified
We are investigating reports of degraded performance for Logins.
Posted May 28, 2021 - 17:49 CEST
This incident affected: Logins.