Issues with banking operations
Incident Report for SumUp
Resolved
The incident was resolved. We monitor the activity of our services and everything is back to working as usual. Thank you for your patience.
Posted Mar 20, 2023 - 19:56 CET
Monitoring
Card transactions, Business account onboarding, card issuing and management is now operational. We will keep monitoring the systems.
Posted Mar 20, 2023 - 17:23 CET
Identified
The issue with our banking system has been identified and our engineers are working on a solution. The issue is currently affecting card transactions, business account creation, card issuing and management.
Posted Mar 20, 2023 - 15:00 CET