Issues with Payments
Incident Report for SumUp
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 12:53 CET
Monitoring
We're seeing normal operations again. We're continuing to monitor.
Posted Nov 16, 2021 - 12:45 CET
Update
We're seeing some improvements, we're continuing to resolve issues.
Posted Nov 16, 2021 - 12:32 CET
Identified
We've identified a problem with our payments processing.
Posted Nov 16, 2021 - 12:19 CET
This incident affected: Payments.