Issues with Marketing website
Incident Report for SumUp
Resolved
All marketing website pages should now be working as expected.

We're terribly sorry for the disruption, and we very much appreciate your patience.
Posted Mar 23, 2021 - 16:26 CET
Investigating
The marketing website isn't working as expected and most pages fail to load. We're working to resolve this issue, and we're sorry for the trouble.
Posted Mar 23, 2021 - 16:13 CET
This incident affected: Marketing Website.