Issues with Logins and Payments
Incident Report for SumUp
Resolved
The incident has been resolved. All users should be able to log in and transact normally. Please contact our support team if you're still experiencing issues.
Posted Jan 26, 2021 - 05:36 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2021 - 05:33 CET
Investigating
We are investigating reports of degraded performance for our Logins and Payments.
Posted Jan 26, 2021 - 05:29 CET
This incident affected: Payments and Logins.