Issues with the 3G in the Netherlands
Incident Report for SumUp
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 18:34 CET
Investigating
We are investing an issue with the 3G terminal in the Netherlands.
Posted Mar 01, 2022 - 15:28 CET
This incident affected: Payments.