Issue processing card payments in Germany
Incident Report for SumUp
Resolved
Due to a technical issue, there were problems with card transactions in Germany
Posted May 24, 2023 - 09:00 CEST