Issue with Payments
Incident Report for SumUp
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 13:33 CET
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 13:03 CET
Monitoring
We're continue to monitor. Some issues are still visible.
Posted Nov 16, 2021 - 12:56 CET
This incident affected: Payments.