Issues with Payments
Incident Report for SumUp
Resolved
We've resolved the issue, and all impacted customers should now be able to take payments. Thanks for bearing with us and we apologize for the disruption.
Posted Jun 24, 2022 - 20:59 CEST
Update
We're continuing to see signs of improvement and are monitoring the situation.
Posted Jun 24, 2022 - 20:50 CEST
Monitoring
We are seeing improvements and most payments should be going through normally again. We'll be back with another update as soon as we have more information.
Posted Jun 24, 2022 - 20:34 CEST
Update
We're still investigating the elevated error rates. We do apologize for any disruption.
Posted Jun 24, 2022 - 20:29 CEST
Investigating
We are investigating elevated error rates with payments. We’re on the case and will provide another update once we have more details to share. We’re sorry for the inconvenience.
Posted Jun 24, 2022 - 20:10 CEST
This incident affected: Payments (Card Readers).