Issues with Logins
Incident Report for SumUp
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 21:47 CET
Investigating
We are investigating reports of degraded performance for Logins.
Posted Oct 28, 2020 - 21:37 CET
This incident affected: Logins.