Issues with Payments
Resolved
Partial outage
Lasted for 28m

The issue has been resolved and all users should be able to transact. We're terribly sorry for the disruption, and we very much appreciate your patience.

Fri, Oct 8, 2021, 10:20 AM
2 years ago
Affected components
Updates

Resolved

The issue has been resolved and all users should be able to transact. We're terribly sorry for the disruption, and we very much appreciate your patience.

Fri, Oct 8, 2021, 10:20 AM
14m earlier...

Monitoring

Our systems are recovering and most users should be able to transact again. We're monitoring the situation will report back as soon as we have an update to share. We're sorry for the inconvenience in the meantime.

Fri, Oct 8, 2021, 10:05 AM
13m earlier...

Investigating

There appear to be connectivity issues for our payments. We're investigating now and will be back with more information as soon as it's available, or in 15 minutes.

Fri, Oct 8, 2021, 09:51 AM