Issues with Online Payments
Resolved
Partial outage
Lasted for 1h

All online payments are working again. We're terribly sorry for the disruption, and we very much appreciate your patience.

Fri, Feb 26, 2021, 12:16 PM
3 years ago
Affected components
Updates

Resolved

All online payments are working again. We're terribly sorry for the disruption, and we very much appreciate your patience.

Fri, Feb 26, 2021, 12:16 PM
14m earlier...

Monitoring

Recurring online payments are being re-routed through a different provider as well. All online payments should work again. We are continuing to monitor the situation.

Fri, Feb 26, 2021, 12:02 PM
15m earlier...

Identified

One-time online payments should work again as we are re-routing them through a different provider. We are continuing to work on a solution for recurring online payments.

Fri, Feb 26, 2021, 11:46 AM
16m earlier...

Identified

We are continuing to work on mitigating this issue and will continue to provide updates every 15 minutes.

Fri, Feb 26, 2021, 11:30 AM
18m earlier...

Identified

Online payments with cards are failing at the moment due to an issue at an upstream provider. We’re working on a mitigation.

Fri, Feb 26, 2021, 11:11 AM