Invoice sending interrupted
Resolved
Partial outage
Lasted for 28m

The issue has been fixed
Invoice sending functionality has been restored

Mon, Mar 25, 2024, 09:06 AM
1 month ago
Affected components
Invoices
Updates

Resolved

The issue has been fixed
Invoice sending functionality has been restored

Mon, Mar 25, 2024, 09:06 AM
28m earlier...

Investigating

An issue has been identified, we’re looking into it

There’s currently an issue with SumUp invoices. Our engineering team is working to fix it right now, the service will be available again shortly.

Mon, Mar 25, 2024, 08:38 AM