SumUp Services performing slowly
Resolved·Degraded performance

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Fri, Jan 24, 2025, 03:48 PM
(5 months ago)
·
Affected components
Dashboard
Logins
Updates

Resolved

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Fri, Jan 24, 2025, 03:48 PM

Resolved

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Fri, Jan 24, 2025, 11:08 AM(4 hours earlier)

Monitoring

Applied a fix for the problem, we’re monitoring the situation

SumUp services have returned to normal. Our engineering team will monitor the situation to make sure the issue is solved. We’ll post current information here on our status page.

Fri, Jan 24, 2025, 10:45 AM(23 minutes earlier)

Monitoring

We identified a performance issue in our system.

Some users may experience slow performance on SumUp services, especially in the Web Dashboard.

Fri, Jan 24, 2025, 10:19 AM(25 minutes earlier)