Mastercard/Maestro transactions is facing issue Globally
Resolved
Degraded performance

Issue is fixed globally from Mastercard, Transactions are back to normal. Mastercard network transactions are back to normal and we consider it closed for now

Sun, Mar 9, 2025, 10:13 AM
9h ago
Affected components
Updates

Resolved

Issue is fixed globally from Mastercard, Transactions are back to normal. Mastercard network transactions are back to normal and we consider it closed for now

Sun, Mar 9, 2025, 10:13 AM
13m earlier...

Monitoring

Issue seems to be fixed from Mastercard/Maestro It appears to us that the issue is fixed from Mastercard/maestro, we are currently monitoring it closely.

Sun, Mar 9, 2025, 09:59 AM
1h earlier...

Identified

An issue is identified with Mastercard/maestro network Globally. There is an ongoing issue related to Mastercard/maestro network globally, SumUp team is having a closer look and will share an update on our status page.

Sun, Mar 9, 2025, 08:52 AM
28m earlier...

Investigating

An issue has been identified, we’re looking into it There’s currently an issue with some Italian issuers/Banks. Our engineering team is looking into that at the moment. You can find up-to-date information here on our status page.

Sun, Mar 9, 2025, 08:23 AM