Some Merchants may experience issues when logging in
Resolved·Degraded performance

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Wed, Oct 30, 2024, 01:39 PM
(7 months ago)
·
Affected components
Logins
Updates

Resolved

The issue has been fixed and we’re confident it’s resolved

SumUp services have returned to normal. You can stay up to date on the status of our services anytime here on our status page.

Wed, Oct 30, 2024, 01:39 PM

Identified

We identified the root cause and are working on a fix.

Wed, Oct 30, 2024, 12:20 PM(1 hour earlier)

Investigating

We identified an issue with our Logins

We identified an issue in our login system that prevents a small number of merchants from logging in.

Wed, Oct 30, 2024, 12:18 PM