Resolved
We have identified the issue. All merchants should see their sales and transactions
Monitoring
We identified the issue and all payments are being processed. All merchants should see their sales now
Investigating
An issue has been identified, we’re looking into it
There’s currently an issue with some SumUp services. Our engineering team is working to fix it right now. You can find up-to-date information here on our status page.